something is wrong with rewrite

Topics: User Forum
Sep 28, 2006 at 7:00 PM
Hi!
I think that this is very powerfull thing, but, still not working for me.

please help.

I wanna try it with local iis
I instaled the dll in the folder in my web site

in my .ini file I have only rewrite lines:

RewriteLogLevel 3
RewriteRule ^/(^/+)$ /default.asp?j=$1

Thu Sep 28 20:58:11 2006 - HttpFilterProc SFNOTIFYPREPROC_HEADERS
Thu Sep 28 20:58:11 2006 - DoRewrites
Thu Sep 28 20:58:11 2006 - New Url: '/davorphotos/esp/'
Thu Sep 28 20:58:11 2006 - ApplyRules (depth=0)
Thu Sep 28 20:58:11 2006 - Rule 1 : -1
Thu Sep 28 20:58:11 2006 - Rule 2 : -1
Thu Sep 28 20:58:11 2006 - Rule 3 : -1
Thu Sep 28 20:58:11 2006 - Rule 4 : -1
Thu Sep 28 20:58:11 2006 - Rule 5 : -1
Thu Sep 28 20:58:11 2006 - Rule 6 : 2
Thu Sep 28 20:58:11 2006 - Condition: checking '127.0.0.1' against pattern '^(?!127.0.0.1)(0-9{1,3}.0-9{1,3}.0-9{1,3}.0-9{1,3})(.*)$'
Thu Sep 28 20:58:11 2006 - Condition false, Rule does not apply (rc=-1)
Thu Sep 28 20:58:11 2006 - Rule 7 : -1
Thu Sep 28 20:58:11 2006 - Rule 8 : -1
Thu Sep 28 20:58:11 2006 - Rule 9 : -1
Thu Sep 28 20:58:11 2006 - Rule 10 : -1
Thu Sep 28 20:58:11 2006 - Rule 11 : -1
Thu Sep 28 20:58:11 2006 - Rule 12 : -1
Thu Sep 28 20:58:11 2006 - Rule 13 : -1
Thu Sep 28 20:58:11 2006 - Rule 14 : -1
Thu Sep 28 20:58:11 2006 - Rule 15 : -1
Thu Sep 28 20:58:11 2006 - Rule 16 : -1
Thu Sep 28 20:58:11 2006 - Rule 17 : -1
Thu Sep 28 20:58:11 2006 - Rule 18 : -1
Thu Sep 28 20:58:11 2006 - Rule 19 : -1
Thu Sep 28 20:58:11 2006 - Rule 20 : -1
Thu Sep 28 20:58:11 2006 - Rule 21 : -1
Thu Sep 28 20:58:11 2006 - Rule 22 : -1
Thu Sep 28 20:58:11 2006 - Rule 23 : -1
Thu Sep 28 20:58:11 2006 - Rule 24 : -1
Thu Sep 28 20:58:11 2006 - Rule 25 : -1
Thu Sep 28 20:58:11 2006 - Rule 26 : -1
Thu Sep 28 20:58:11 2006 - Rule 27 : -1
Thu Sep 28 20:58:11 2006 - ApplyRules: returning 0
Thu Sep 28 20:58:11 2006 - No Rewrite


I think that you see what I'm trying to do, I wanna put a quiery string 'j' in rewrite

if you can do something, please.
thanx

davor
Coordinator
Oct 3, 2006 at 12:03 AM
your log file shows that IIRF is processing 27 rules.
At least one of them (Rule 6) includes a RewriteCond.

So you don't have IIRF installed the way you think you do.

check the ISAPI configuration, specifically the location of the DLL, again.