configuring iirf.dll on a network location

Jun 10, 2010 at 9:34 PM

I have 6 iis 6.0 servers behind a load balancer and I am hoping to utilize a centralized .dll location for all 6 of the servers.

Would anyone be able to point me to documentation or an existing discussion that covers this?

This is what I have tried thus far.

1) Created a custom account for an application pool(AP). Added this account to the local IIS_WPG group on the IIS server.
2) Gave the AP account permissions to the network share.
3) Created an application pool running with the AP account identity.
4) Configured the web site's application pool(s) to the above pool.
5) Change credentials used to connect a web application's home directory to a network share to the AP account credentials.

I then configured the isapi filter to point to \\share\iirf\iirf.dll.

I verified that Network Service has read and execute permissions on iirf.dll and iirfglobal.ini and the directory containing these files.

After restarting IIS I am getting the red down arrow.   Nothing is showing up in the event viewer application log.

thanks in advance for your suggestions




Jun 16, 2010 at 9:14 PM
Edited Jun 16, 2010 at 9:15 PM

did you try the basic troubleshooting, as described in the documentation?

in your case you might check the Windows event log...

Also check to see if there is an IIRF log file. 

Jun 17, 2010 at 12:19 AM


Yes, I went through all the basic troubleshooting as described in the documentation.

As I mentioned earlier I didn't see anything in the event viewer log, but I didn't check to see if a IIRF log was being created.  Since then, I had I checked but I didn't see evidence of a log file.

Also, the iirfStatus page was not coming up.

For now, I have given the "everyone" group read and execute access to the .dll,.ini and directory containing these files and that is working but I would like to tighten things up in the future.

Jun 17, 2010 at 1:48 AM

Well it sounds like you've diagnosed the problem - it's a permissions issue.  At this point you just need to make sure you use the proper permissions.

Normally that is IIS_WPG on IIS6.

But I'm sure you will be able to figure it out yourself.

Jun 17, 2010 at 11:22 AM

Thanks for the feedback and thanks for providing this software.

I will update the thread when I find the permissions combination that worked.