ASP.NET 4, eurl.axd, and IIRF

Topics: Developer Forum, User Forum
Dec 14, 2010 at 1:31 PM

I'm adding this as a note for anyone who has been having the same problem as I have been experiencing for the last day of trying to get IIRF working on both a client's IIS6 install and my own.

I initially installed IIRF manually, and then by the msi installer, and each time I could get the ^/cart rewrite rule example to work but the /iirfStatus page refused to show (404 every time) no matter how many changes I made to config files etc.  I also couldn't get logging to work.  The only other ISAPI filter installed is the latest ASP.NET 4.

Today, after reading the instructions on logging and permissions again and checking permissions ultra-thoroughly, I got logging to finally work! which revealed the following line:

     /iirfStatus/eurl.axd/389171ccade74948989645c899c6100d

which some research tells me that by default ASP.NET 4 hijacks any urls that do NOT have a file extension (or something).  I am not a .NET developer and to me this is just insane.  Luckily there is a registry change that can be made to turn this default behaviour off, and can be found here:

     See: http://www.asp.net/learn/whitepapers/aspnet4/breaking-changes
     Find: section “ASP.NET 2.0 Applications Might Generate HttpException Errors that Reference eurl.axd”
     Use: option 3

I hope this helps someone else avoid tearing their hair out as more IIS installs come with .NET 4 activated.

Coordinator
Dec 14, 2010 at 2:00 PM

Thanks very much for the note.

This came up previously - Back in July there was a thread on this forum that discussed the issue.

Your reminder is a good one, though. 
People who run ASPNET v4 and IIRF, or really, ASPNET V4 and any ISAPI Filter, should be aware of the issue with eurl.axd.

The thread from July 2010 discusses the issue in some detail, as well as some options for avoiding it or dealing with it.