rewrite problem with install or corrupt data?

Topics: User Forum
Jan 28, 2011 at 11:36 PM

I installed the newest version of 2.1 over a 2.0 install, and have run into issues when trying to test
rewrite filters.  I built a list of urls and run them through the TESTDRIVER utility and get this:

C:\Program Files\Ionic Shade\IIRF 2.1>testdriver -d c:\inetpub\<mydir>

TestDriver: linked with 'Ionic ISAPI Rewriting Filter (IIRF) 2.1.1.25 x86 RELEASE'.
TestDriver: The IIRF library was built on 'Jan  7 2011 07:30:24'

Trying to read config at 'c:\inetpub\<mydir>\Iirf.ini'
done reading new config
Processing URLs...(c:\inetpub\<mydir>\SampleUrls.txt)


NO REWRITE '/dummy/' ==> --

NO REWRITE '/default.html' ==> --
ERROR expected(╞é|@ùê|♫╞é|@ùê|╝ε↕)
        actual(NO REWRITE)

1 Errors in 1 Total Trials

 

HELP! What is going on with the gibberish that is coming out of the error stream?

I do also have HTTPZIP installed as an ISAPI filter to improve compression on IIS6 but this never caused an issue
with the older version of rewrite 2.0.

Any ideas?

Coordinator
Jan 31, 2011 at 12:35 PM

It could be a simple problem of a bug in the testdriver program.

What does your sampleurls.txt file look like?  Can you post it here?

 

Jan 31, 2011 at 9:18 PM
Edited Jan 31, 2011 at 11:48 PM

Pretty simple.

the first two are to verify it's skipping the urls that don't match the pattern.  The third is an actual one that should match
changing to a url like:   /ourteam.html?F=$2&L=$1

/dummy/
/default.html
/rebarcpa/aubrey/don

But when I run it, I get the garbage chars you see above.

oh, and as a side note, the isapi filter is not processing in the site either, and I finally had to remove
it altogether because it caused the entire IIS server to lock up.

Peter

Coordinator
Feb 2, 2011 at 1:31 PM

oh! Ok, well if you removed everything, then you have no more questions?   or are you still trying to get this to work?

 

Feb 7, 2011 at 5:48 PM

Of course I want it to work.  But I can't leave it installed and not working.  I have tried installing it and uninstalling it and cleaning up the remnants 3 times. I NEED it to work.  It's not a matter of want.

Every time, I get the corrupted results and it never does the rewrite correctly.

ideas?

Feb 7, 2011 at 6:37 PM

I addition, I installed it on a third server, out of the cluster, and this is more of a development server.

raised the log level lto 3 but and it appears that no matches to the regex rules are taking place so there
is no rewriting going on.  This is kind of frustrating.  It's a Very simple rewrite file and basically copies
the examples for rewriting ugly urls.

At least on the home server, the amount of gibberish is down to 2 characters from the long string above.

This leads me to believe that there is some component missing that the dll is counting on? Perhaps an updated
regex library or something I am missing?

I'm running on windows server 2003.

peter

Feb 7, 2011 at 7:27 PM

ok, consider this closed:

the rewrite rule was missing one syntax problem.

I had /rebarcpa/(.*)$/(.*)$   as the regex match, and the real match needs

to be:  /rebarcpa/(.*)/(.*)$ to work properly.

When all else fails.  check the cable.  Duh!

Although, I'm still confused by the gibberish output when it reports an error.  just doesn't seem friendly.