Can't Install on 64-bit Windows 2008 R2 IIS7.5

Topics: Project Management Forum, User Forum
Apr 20, 2011 at 6:11 PM

I'm receiving the 2801 error.  Which I have looked in other posts first.  What seems different about this one is that after it gives me the 2801 error it reports the exception "wantstate" is undefined.

Coordinator
Apr 25, 2011 at 5:30 PM

Hmm, yes, my installer for the latest version is broken, I think on x64.  I will look into this as soon as possible and try to get a fix up.

Coordinator
Apr 25, 2011 at 5:30 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Apr 25, 2011 at 8:43 PM

ok, I put a patched MSI file on the workitem.  If you are still interested, please try it and let me know.

Apr 25, 2011 at 9:13 PM

Still no go.

 

Here is a screen capture of the error message.

Thanks for you help.

Coordinator
Apr 25, 2011 at 10:16 PM

Thanks for that.

Problem is, I lost my main development machine some time back (== it died), and with it, I lost the VM for Windows Server 2003, so I cannot effectively test the installation on IIS6.

BUT, I thought I fixed the problem you are reporting. Is this the exact same symptom that you saw previously?  The changes I made to the MSI ought to have fixed that.

The IIRF x64 MSI that has the fix is like this:

04/25/2011  04:35 PM         3,631,104      Iirf2.1-x64.msi

MD5: 2A53D2C046175865FDCC3DCBD6428DAF
SHA1: 6F35547C75F33166C19FC0E580C3D999740AC93E

Can you make sure this is the one you are trying to install, when it fails with that "wantstate" message?

If this is the one you're using, then I guess there is a problem with the build system on my end.  Maybe I am not pushing out the fixed build, somehow.

let me know.

Apr 26, 2011 at 7:02 PM

I had the exact same error message with the newest installer on an X86 Windows Server 2003. Using the previous version the install was successful.

Coordinator
May 2, 2011 at 6:43 PM

ok, lilbubba, have you tried the updated installer available for download from http://iirf.codeplex.com/workitem/30599 ??

May 8, 2011 at 12:35 PM
Edited May 8, 2011 at 12:37 PM

i'm running iis6 on a 64bit windows 2003 server. 2.1.1.26 (from workitem 30599) which installs ok (i don't get the wantstate error as i do with the 2.1 x64 version off the main download page) but i do get a red down arrow on the isapi control in iis mngr. my web site stops responding and i get an event viewer entry W3SVC-WP "Could not load all ISAPI filters for site/service. Therefore startup aborted."

i checked the dll security permissions etc and all appear as per the helpp file (same for the ini file too).

i'm at a loss how to get this working. works fine on x86 windows 2003 server iis6 but not 64bit.

Oct 18, 2011 at 2:17 AM

To make IIRF work well on Windows Server 2008 X64,you can try to follow the steps http://iirf.codeplex.com/discussions/276031  ,already tested on Windows Server 2008 x64 ,good luck to you :)