weird redirect... eurl.axd appears in the URL

Topics: User Forum
May 26, 2011 at 5:36 PM
Edited May 29, 2011 at 10:11 AM

Hi all

I'm using IIRF for redirecting http://domain.com to http://www.domain.com and it's been superb, however I've recently noticed a weird issue when used with a CMS (Umbraco, maybe others).

When on the home page, IIRF redirects to a long and weird path.  The resultant path is http://www.domain.com/eurl.axd/314711f7bc801e4ea04b5bada5cdd6b7/.  What's weird is that it still displays the site.  Also, any page beneath http://domain.com/page redirects to www.domain/page without the extra weird path.

Here's the IIRF.ini


 RewriteCond %{HTTP_HOST} ^domain\.com$ [I]
 RedirectRule ^/(.*) http://www.domain.com/$1 [R=301]

Any thoughts from the gurus?

Many thanks
Lea

Coordinator
May 27, 2011 at 8:21 PM

yes that's a known issue - it's an interaction between ASPNET 4 and IIRF (and other redirect filters). 

Check this older thread: http://iirf.codeplex.com/discussions/248189

May 29, 2011 at 10:24 AM

Thanks Cheeso - you're a star as always.

I've added the reg key and IIRF is working as expected :) :), but the browser window now displays the file extension (.aspx) which I suspect is what the ASPNET 4's filter was hiding all along.

So, with ASPNET filter, sites look modern without aspx extensions displayed in the browser : www.mysite.com/contactus 

disable the ASPNET filter by reg key and we now have: www.mysite.com/contactus.aspx displayed

But we all know that for SEO we need redirects from mysite.com to www.mysite.com

Uhm, life's complicated enough...lol

Thanks once again Cheeso - brill product, shame MS are fiddling!

BTW I tried installing the latest Iirf2.1-x86.msi on W2K3 SP2 R2 but get - Exception {EnumerateWebSites}: 0x800A1391 : 'wantstate' is undefined.  I had to revert to a previous IIRF 2.1 install.

Lea

Coordinator
May 29, 2011 at 9:38 PM

Thanks for reporting that Lea - will get that looked at.

Coordinator
May 29, 2011 at 9:39 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Aug 11, 2011 at 11:08 PM
Edited Aug 11, 2011 at 11:09 PM

I ran into a similar issue with v4.0 ASP.Net extension less URL feature on II6 and found a solution through ISAPI Rewrite Module provider, the does not require turning it off.  Theissue and the solution as we experienced it is documented here EURL.axd Fix

Coordinator
Aug 12, 2011 at 12:21 AM

That link points nowhere?

 

Aug 24, 2011 at 4:14 AM
Edited Aug 24, 2011 at 4:14 AM

I think this might be where the link was supposed to go:

http://www.vanadiumtech.com/OurBlog/post/2011/08/12/Cause-of-eurlaxd.aspx

Is there any way to use this as a model config for setting up IIRF so we don't have to make a universal, server-wide change?  (Thanks!)

Aug 24, 2011 at 4:26 AM

Well, I sort of answered my own question!  It just took some elbow grease in my case. I just had to add the (/eurl.axd/.*) string after the test strings and before the $ in all my redirect rules.  And that worked great for me.  And I didn't have to make the server-wide registry change. 

If any side-effects can arise from this approach, I'd love to know.  Thanks very much for your feedback!

Once again, and as always - thanks for IIRF and for this forum!  :)

Coordinator
Aug 24, 2011 at 3:49 PM
Edited Aug 24, 2011 at 7:41 PM

The approach sounds fine, glad its working for you.