Windows Server 2008 64-bit - IIRF not loading, IIS7

Topics: User Forum
Jun 3, 2011 at 9:23 PM

Hi,

I'm using windows server 2008 64-bit, with IIS7.  I had to go the manual route because of the x64 installer error.  Have tried with both x64 and x64 versions.

I have everything set up as far as I can tell, including permissions to the IIS_IUSRS group on the dll and ini.  I added the ISAPI Filter, and restarted IIS and tried to go to /iirfStatus but it just 404s.  I've tried looking in the Event Viewer and even IIS logs, no mention of IIRF at all.  Any help would be appreciated.

Oh, under ISAPI Filters, since we are using a .NET app, there were originally two entries: ASP.Net_2.0.50727.0 "%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_filter.dll" and ASP.Net_2.0.50727-64 "%windir%\Microsoft.NET\Framework64\v2.0.50727\aspnet_filter.dll".  I also tried reordering this to put the IIRF entry at the top with no results.  IIRF and .NET are compatible though, right?

-Andrew Roth

Coordinator
Jun 4, 2011 at 2:38 AM

You can have IIRF and .NET running on the same machine.

Not sure what to tell you about the 404 errors.  There's a "Verifying and Troubleshooting Installation" page in the manual that may be helpful.

It's usually not really complicated to get it installed. Permissions issues are the #1 source of problems.

Good luck.

 

Jun 6, 2011 at 2:43 PM

Is there a way to see a log file that would show if it's a permission issue?

Jun 6, 2011 at 3:36 PM

Aha - it works if I go to http://localhost/iirfstatus but not if I go to the public IP with /iirfstatus.  Is that expected?

Coordinator
Jun 8, 2011 at 12:04 AM

Yes Andrew, that is expected behavior.

Check the documentation on the StatusInquiry directive for more information.