Joomla

Topics: User Forum
Jan 11, 2007 at 7:35 PM
Hi,

I'm using Joomla on IIS since some time and now I wanted to get search friendly URLs. I've installed the ISAPI Rewriter and the ARTIO JoomSEF Component. The strange thing is, that sometimes I get the page displayed with the blabla.html URL and sometimes I get 404. And this for the same page ... Sometimes I have to reload the page severall times and then the page appears correctly.

Does anyone has an idea why the ISAPI Rewriter is sometimes working and sometimes not?

My INI looks like that:


RewriteLog c:\temp\iirfLog_3.out
RewriteLogLevel 4

  1. MaxMatchCount
#
  1. Specifies the maximum number of sub-expression matches to
  2. capture for a single pattern. This specifies the size of the
  3. array in the C module. If you have a pattern with more than
  4. the default number of matches, set this number.
#
  1. The default is 10.

MaxMatchCount 10


#RewriteCond %{URL} ^(/component/option,com) NC,OR ##optional - see notes##
RewriteCond %{URL} (/|\.htm|\.php|\.html|/^.*)$ NC
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule /(.*) /index.php U
Jan 11, 2007 at 9:38 PM
Exactly the same problem here.

http://www.codeplex.com/IIRF/WorkItem/View.aspx?WorkItemId=7228
Jan 12, 2007 at 9:00 AM
Thanx. And is there a solution available how to solve that? Is it a IIRF bug (if so I don't have to fiddle around with the settings to get it working).

BR
Jan 12, 2007 at 10:42 AM
Hello,

I'm not 100% sure if it is IIRF bug, but it seems so according to the logs and also you having exactly the same problem on different server confirms that.

Hopefully author(s) or other users familiar with IIRF soucres could check this.

Best regards,
Michal
Jan 17, 2007 at 1:07 AM
Hello,

just to let you know, as we did not receive any reaction about the error we have reported, we have configured Joomla! with JoomSEF using ISAPI_Rewrite filter for IIS.

If you need help installing it, contact support@artio.net.

Best regards,
Michal
Coordinator
Mar 1, 2007 at 10:02 PM
I believe this is an IIRF bug, but I believe it is fixed in any 1.2.11 version.

In the future when you report a difficulty, it would help greatly if you'd include the exact version number of the IIRF software you're using. The version # is printed in the log upon IIRF startup.

-Cheeso