IIRF doesn't seem to load

Topics: Developer Forum, User Forum
Dec 24, 2008 at 5:25 AM
I have used IIRF before on WIndows 2003/IIS 6 sometime back, now when I am trying to install and configure on a new server IIRF doesn't seem to load, No error messages, no redirection, nothing.

I am trying to list the steps I followed:
  1. copied the .dll and .ini files to a folder d:\iirf\
  2. gave read permisision to IUSR_hostname and IIS_WPG to this folder
  3. created a log folder called d:\iirf\log and gave write permission to both the above users to this folder
  4. installed ISAPI filter on default website and enabled web service extenion to d:\iirf\IsapiRewrite4.dll
  5. made a simple rewrite rule -
    • RewriteLog  D:\iirf\log
      RewriteLogLevel 5

      RewriteRule  ^/test /index.asp

The ISAPI filer is loaded and is green, the web service extension is 'Allowed'. have tested the ini file with testdriver.exe and found to be working, but redirection does not work and no log file is written too.

Where am I going wrong?


Dec 24, 2008 at 4:57 PM
I have finally managed this to work. The reason I found was permissions to the IsapiRewrite4.ini and IsapiRewrite4.dll. Even though the documentation says they need read+execute permissions for iusr_host and IIS_WPG, this did not work for me. I had to give FULL permisisons to both and its working.
Jan 8, 2009 at 4:39 PM
Hi. I ran to a worse problem - the ISAPI filter is NOT loaded, no green up arrow, only red down arrow. My first setup is similar like yours, and my second setup is identical to yours, but it still doesn't work. Do you have any suggestion on how to turn it on? Should I copy the source and rebuild it from beginning? Thanks.