Modx CMS Converting htaccess Conversion for SEO URLS

Topics: Developer Forum, Project Management Forum, User Forum
Aug 13, 2009 at 2:49 PM

I have this htaccess:

# Vital components of your .htaccess file
RewriteEngine On
RewriteBase /

# Force “www.yourdomain.com” instead of just “yourdomain.com”
RewriteCond %{HTTP_HOST} .
RewriteCond %{HTTP_HOST} !^www\.domain\.com [NC]
RewriteRule (.*) http://www.domain.com/$1 [R=301,L]

# The Friendly URLs part
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Would anybody please convert it or tell me if it will work with Ionics Isapi Rewrite Filter. This would be so useful guys :D
Coordinator
Aug 13, 2009 at 4:37 PM
Edited Aug 13, 2009 at 4:38 PM

try this...

# Vital components of your IIRF ini file
RewriteEngine On
#RewriteBase /

# Force “www.yourdomain.com” instead of just “yourdomain.com”
RewriteCond %{HTTP_HOST} .
RewriteCond %{HTTP_HOST} ^(?!www\.domain\.com) [I]
RedirectRule ^(.*)$ http://www.domain.com$1 [R=301]

# The Friendly URLs part
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Aug 14, 2009 at 4:07 PM

Does anything from this thread apply?

 

http://www.codeplex.com/Thread/View.aspx?ProjectName=IIRF&ThreadId=15510&ANCHOR

Coordinator
Aug 14, 2009 at 4:10 PM

Are you asking if the filter understands the QSA modifier?  Yes, IIRF now handles QSA.

Try it and see.

Also, you might want to read the doc.

 

Aug 14, 2009 at 4:31 PM

Ok I dont think the config is wrong just cant get the plugin started.

"The HTTP Filter DLL C:\WINDOWS\system32\inetsrv\IIRF\IsapiRewrite4.dll failed to load. The data is the error."

and

"Could not load all ISAPI filters for site/service. Therefore startup aborted."

 

Any ideas?

Coordinator
Aug 14, 2009 at 5:01 PM

yes: check the doc on how to troubleshoot startup issues.

 

Aug 17, 2009 at 3:38 PM

When we run IIS with the plugin and it doesnt start all the pages just load blank with no source code.

Coordinator
Aug 17, 2009 at 4:03 PM

OK, and if you check the doc on how to troubleshoot, you may be able to figure out why the filter doesn't start.