Rewrite rule help

Topics: User Forum
Feb 28, 2007 at 10:55 PM
Edited Feb 28, 2007 at 10:57 PM
Hi Cheeso,

I have to create a rewrite rule for

http://www.mysite.com/myfile.php?id=some_number

with the following result:

http://www.mysite.com/some_number/

I've try to do but with no good result. Can you help me?

Best regards

Adrian
Mar 1, 2007 at 12:10 PM
Well, I'm no Cheeso but...

RewriteRule /(\d+) /myfile.php?id=$1 [U]
Coordinator
Mar 1, 2007 at 9:06 PM
Good call csi95.

There is a similar rule given as an example in the readme, Example #4.

also, please check the tests directories for other examples.
<iirfinstalldir>\tests\

and do use the testdriver.exe to check your rules.

-The Big Cheese
Mar 2, 2007 at 10:37 AM
Thanks csi95 and Cheeso for your help, I try to do this and I'll post the result.

Best regards
Mar 5, 2007 at 4:49 PM
Edited Mar 5, 2007 at 5:30 PM
Hi csi95 and Cheeso

I've applied this rule but the result is Error 404. I've run testdriver and the rule is ok but on line fail.

I need input an url write like:

http://www.mysite.com/some_number/

and execute the script like

http://www.mysite.com/myfile.php?id=some_number.

The IIRF isapi filter was well installed for the site and also set the permissions right.

I will thanks any idea.

Adrián
Coordinator
Mar 5, 2007 at 6:03 PM
ok, some questions:

1. the testdriver tool seems to indicate the rule is correct, is that right?

2. with the IIRF running in the server, when you submit a URL like http://www.mysite.com/some_number/
then you do not get the result you expect, is that right?

3. can you show me the IIRF logfile (with logLevel set to 3 or above) ?


thank you
Mar 5, 2007 at 10:34 PM
Edited Mar 5, 2007 at 10:40 PM
Cheeso, thanks for your answer, but this is very hard for a beginner like me.

I'm answering your questions:

1. that's right
2. that's right
3. I set the RewriteLog C:\Inetpub\vhosts\mysite.com\httpdocs\Temp\iirf
and set the write permission to Temp directory, but iirf isapi filter do not write the log file. Also when I restarted the server, all the page for mysite.com are crashed (or 500 error). If I disable the filter all return to the normal state.
This error was not doing before. This has disoriented me.

Note, I had enable permission for IIRF dll on my IIS, previus add the filter to the site.

Best regards

Adrian
Coordinator
Mar 5, 2007 at 10:51 PM
Adrian,

2 things:
#1: your logfile directory should not be a child of the web directory. there is a dire warning about this in the IIRF readme file. I cannot tell if you have done this or not, but maybe you have. I might guess that your web directory is c:\inetpub\vhosts\mysite.com\httpdocs and you have asked IIRF to log into the Temp\iirf subdirectory underneath that directory. If that is the case, DON'T DO THAT. See the readme for why. You may wish to re-read the entire README file. it is helpful .

#2
it sounds as though IIRF may not be properly installed. you said that "the IIRF ISAPI filter was well installed" but have you verified that? if so, how? one sure way to verify that IIRF is properly installed is to see the output of the IIRF filter in the logfile. if you see log messages, then you know IIRF is running. If you do not see a logfile, nor log messages, then IIRF is likely not properly running.


have you tried troubleshooting the installation of the IIRF filter according to this article? http://blogs.msdn.com/david.wang/archive/2005/06/21/HOWTO_Diagnose_and_Fix_Common_ISAPI_Filter_Installation_Failures.aspx

or also try this: http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/93f23233-2a47-4104-b0b4-a7ec0d3116f3.mspx?mfr=true