Setup cannot continue

Dec 15, 2009 at 7:55 AM

Hello,

I'am trying to install iirf on a Windows 2003 machine with iis 6.
I want to install all the components and after the next button, i select the website 'W3SVC/1925757419' aka ese-edu.com
After that i click install

On about 90% i got a error saying: "There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact support personnel or package vendor'

 

How can i solve this problem?

 

Regards,

Sander

Coordinator
Dec 15, 2009 at 2:24 PM

I'll have to look at it and get back to you later today.

Dec 20, 2009 at 9:09 PM

Hello, 

I'm also trying to install Ionics server-wide on a Win Svr 2003 server using the msi installer and getting the same message.  The application event viewer shows the MSIintaller error as:

Product: Ionic's ISAPI Rewrite Filter 2.0 -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action CA.AddExtension script error -2146827284, Microsoft JScript compilation error: Expected ';' Line 3, Column 10, Function AddExtension_CA()

Is this fixable or is the only option a manual install?

cheers

Ulric

 

 

 

Coordinator
Dec 20, 2009 at 11:59 PM

I think it's fixable by ME, but probably not fixable by YOU.

 

Dec 21, 2009 at 7:43 AM

Happy with that.  Any idea of a timescale?

Dec 21, 2009 at 3:12 PM

Same Issue !!

Coordinator
Dec 21, 2009 at 5:31 PM
Edited Dec 21, 2009 at 5:44 PM

I should have a fix later Today.

Dec 21, 2009 at 6:33 PM

I can also confirm this issue. Just tried the MSI installer on Windows 2003 w/IIS 6 and got the same error posted above.

Jan 26, 2010 at 6:28 AM

Hi Cheeso, I was wondering what the status is on this error.

I just downloaded the MSI that was released from December 3rd and I got this same error. FYI during install I chose to install server wide if that makes any difference.

I am really interested in trying this rewrite filter. I had tried once in september (before an MSI was availble) and I couldn't figure it out. I was hoping the msi would compensate for my ignorance of installing manually.

Jan 30, 2010 at 12:00 AM

I am having the same issue as well. The same error listed above, 

Product: Ionic's ISAPI Rewrite Filter 2.0 -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action CA.AddExtension script error -2146827284, Microsoft JScript compilation error: Expected ';' Line 3, Column 10, Function AddExtension_CA()

I tried stopping the web I was installing it to, restarting IIS, stopping IIS and running the install... Etc. Etc. No help with any of it.  Please let us all knwo what you want us to do. I am very eager to donate for this if it works for me.

Thank you for your time.

Coordinator
Feb 1, 2010 at 5:08 AM

Sorry it took so long.

Much longer than I expected.

Anyway I believve this is fixed in v2.1.0.11.  Please try it and report your results.

 

Feb 2, 2010 at 2:14 PM
Edited Feb 2, 2010 at 2:15 PM

I just tried v2.1 and I received the same error message. I'm running Windows XP with IIS 6. Please advise.

Coordinator
Feb 2, 2010 at 9:12 PM

You cannot run IIS6 on Windows XP.  Something isn't right with what you are reporting.

 

To help troubleshoot your problem, Run the command:  msiexec /i IIRF2.1.msi  /l*v iirfinstall.log

and then send me the resulting log file (iirfinstall.log)

If you don't have IIRF2.1.msi, then you need to download the latest IIRF v2.1.

 

 

 

Feb 3, 2010 at 3:06 PM

Sorry. I meant Windows Vista. IIS 6 on Vista.

Feb 3, 2010 at 3:24 PM

I'm installing as the administrator and I tried to run the command above immediately after the installation failed. Windows through the following error:

"This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package."

 

Coordinator
Feb 3, 2010 at 8:30 PM

Vista has IIS7, not IIS6.

The error message you reported in your latest mail indicates there is a problem with the MSI, or the MSI cannot be located.

Verify that the MSI is present.  If it is present, download the MSI again. 

Feb 3, 2010 at 8:36 PM

I assure you I am running IIS 6 on Vista. I just double checked. I do have the MSI. Please advise.

 

Coordinator
Feb 3, 2010 at 10:19 PM
Edited Feb 3, 2010 at 10:20 PM

regarding your assurance regarding Vista and IIS6:  It is not possible to run IIS6 on Vista. It is not possible. If you are running IIS6 on Vista, then it is not a supported scenario, and I cannot help you.   I suspect you are running IIS7.   You said you "double checked".  how did you do that?  

Regarding the problems with the MSI, as I said several posts ago, I need the log file from the MSI.  msiexec /i iirf2.1.msi  /l*v iirflog.out

I need the iirflog.out file.   If you cannot run the MSI file at all, I don't know what to advise.  You'll have to troubleshoot your Windows Installer.  Try other MSIs and see if they have similar problems.

I just re-downloaded the IRF v2.1 MSI, and ran it; it works for me.  It's a valid file.

 

 

 

 

 

Feb 3, 2010 at 10:55 PM

I opened IIS and went to Help > About. It shows that I am running IIS 6. Well thanks for trying to help. I guess I'll figure something out....

 

Coordinator
Feb 4, 2010 at 12:52 AM

In IIS Manager on Vista, if you type Help > About, the first line in the dialog box covers the version of Windows, which is 6.0.  Maybe that is confusing you

On Vista, IIS is 7.0. 

 In any case, I need the log file from the MSI session, in order to troubleshoot your problem .

 

 

Feb 11, 2010 at 7:19 PM
Edited Feb 11, 2010 at 7:21 PM

I  have a Windows 2003 Server and I'm getting this error, too.  I downloaded the msi on 2/11/2010.  Here is a screenshot of the Events viewer:

download page says it is: 2.0.1.15 latest stable (http://iirf.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=14394#DownloadId=95555)

Do I need to download 2.1 beta for this to be fixed?



Coordinator
Feb 12, 2010 at 3:38 AM

YES. v2.1 beta is what you need.

Mar 1, 2010 at 5:54 PM

Hullo Cheeso,

I am totally new to this, whole thing.

I am using rackspace cloud server windows server 2008, IIS7 AMD 32 bit

I am surprised after the reading the above posts i am still getting the "...script could not be loaded error" when installing iirf 2.1 beta.

Maybe for troubleshooting purposes, ii had earlier tried to use ARR to access my tomcat applications on port 8080 but it was failing to display anything.

I haven`t unistalled ARR yet. Before i got ARR i had tried JK module ISAPI redirector but it was only working for the server i was using, i could`nt acess the applications from other computers on the internet.

AM hoping with iirf 2 i will at last succeed. This has taken over a week.

So what could be the problem and how best do you advise me to use it with tomcat on port 8080.

Regards

Coordinator
Mar 1, 2010 at 6:42 PM

To troubleshoot IIRF installer errors, I need the MSI log file.  Read this to learn how to get a log file for an installer: http://technet.microsoft.com/en-us/library/cc759262(WS.10).aspx .  Post the MSI log file.  I'd appreciate a new thread, as this one is old and I think it is settled.  your question is a new one.

I don't know what ARR is. 

You can use IIRF with Tomcat on port 8080, but I don't know what your goals are, so I don't know how to advise you. If you want both Tomcat and IIS to be available on port 80, then you don't need IIRF to do that, but you will need the JK connector, I believe.  see http://tomcat.apache.org/connectors-doc/webserver_howto/iis.html  But I'm not an expert on Tomcat, so I don't know, for sure.

Mar 17, 2010 at 7:09 PM

Glad to see progress in this thread. I downloaded and installed the beta today without incident. Win 2003 server, iis 6. Now just have to figure out how to get it to work with joomla.