Blank Page

Jul 2, 2007 at 12:40 AM
Hi, after installation and configuration of the newest version all I get is a blank page!
What did I do wrong?

Jul 3, 2007 at 12:48 AM
not sure!

maybe a blank page is what you SHOULD get. It is impossible for us to know, without seeing your rules, the URL you are rewriting, and your LOGfile which indicates what action the filter took.

we could guess, but that could take FOREVER...
Jul 3, 2007 at 12:38 PM
I took the Blog Engine example file.

The URL is (without anything else).

I'll paste the content of the logfile in a few minutes, too.

  1. PhpBlog.ini
  1. This example shows how one user employed IIRF twith a
  2. PHP-powered blog engine.
  1. Remember to rename this file to IsapiRewrite4.ini ,
  2. or copy this content to a file named IsapiRewrite4.ini
  3. before using it!
  1. Fri, 11 May 2007 12:46

RewriteLog c:\temp\iirfLog.out
RewriteLogLevel 3

  1. MaxMatchCount
  1. Specifies the maximum number of sub-expression matches to
  2. capture for a single pattern. This specifies the size of the
  3. array in the C module. If you have a pattern with more than
  4. the default number of matches, set this number.
  1. The default is 10.

MaxMatchCount 10

  1. /content/blogcategory/0/33/
  1. should translate to
  1. /index.php?option=com_content&task=blogcategory&id=0&Itemid=33

RewriteRule ^/(^/)/(^/)/(^/)/(^/)/$ /index.php?option=com_$1&task=$2&id=$3&item=$4
Jul 3, 2007 at 12:53 PM
The logile is not being created, I'm sorry.
Jul 8, 2007 at 4:01 PM
Please help me, this is really urgent!
Jul 13, 2007 at 5:35 PM
i cannot read your rules. you need to blockquote the rulefile by using double-curly braces.

if the logfile is not being created, that suggests your install is not right.
Jul 13, 2007 at 9:08 PM
It's your default blog configuration file!
Jul 14, 2007 at 12:14 AM
I'm truly sorry IIRF is not working as you expect.
IIRF doesn't have a blog configuration file. There may be a sample you found somewhere, but that was stuff contributed from the community. I don't have that blog system (whatever it is) and I haven't tested it. I haven't done the doc for how to make IIRF work nicely with whatever it is.

Truly sorry about the misunderstanding.
Good luck solving the problem!

Jul 16, 2007 at 2:24 PM

I was talking about this file:

- Ben
Jul 16, 2007 at 3:56 PM
Hey Ben!

Yes! That was contributed by "someone", I don't recall who. It's an example. I haven't tested it. I have updated the comments in that file to state this clearly.

Good luck.
Jul 21, 2007 at 10:07 AM

what else should I do except for adding the filter for the domain I want, and placing
the ini file in the folder where the filter file is located?

- Ben
Oct 7, 2008 at 7:21 AM
I've got the same problem here. All I get is a blank page. In the ISAPI-Filterlist in the IIS-Manager I added the dll, but after restarting the IIS and looking there again it has a red arrow down saying "not loaded". Is that correct behaviour?

And what should happen if I place an empty .ini file in the IsapiRewrite4.dll-dir?

Oct 7, 2008 at 7:34 AM
Well, I can answer it for myself: I had to give read-access to the IIS_WPG group for the dll (though server runs as anonymous user IUSR_hostname), and it works now.