404 Page not found when using IIRF

Topics: Developer Forum, Project Management Forum, User Forum
Oct 26, 2007 at 4:07 PM
Edited Oct 31, 2007 at 3:15 PM
Hello,

I'm trying to use the IIRF to redirect my old domain to my new one.
For exemple, I want to redirect every requests containing "canam.ws" to "canammanac.com".

I installed the IISRF filter and it loaded properly.

I made that rule:
#RewriteLog c:\temp\iirfLog.out
#RewriteLogLevel 3

#=====================================================
  1. Demonstrates RewriteCond with HTTP_HOST.
#
#=====================================================
#RewriteCond %{HTTP_HOST} ^(.*)canam\.ws$ I
#RewriteRule ^.*$ http://intranet11-auth.canammanac.com/homepage.nsf U,L

But when I try it, I receive a 404 page not found error.

Here's the log:
--------------------------------------------
Fri Oct 26 10:12:41 2007 - Read .ini file: setting LogLevel to 3
Fri Oct 26 10:12:41 2007 - ini line 8: RewriteCond %{HTTP_HOST} ^(.*)canam\.ws$
Fri Oct 26 10:12:41 2007 - ParseCondModifierFlags: 'I'
Fri Oct 26 10:12:41 2007 - ini line 9: RewriteRule 1 ^.*$ http://intranet11-auth.canammanac.com/homepage.nsf U,L
Fri Oct 26 10:12:41 2007 - ParseRuleModifierFlags: 'U,L'
Fri Oct 26 10:12:41 2007 - Done reading .ini file: Found 1 rules (0 failed) on 10 lines
Fri Oct 26 10:12:41 2007 - Ionic URL Rewriting ISAPI Filter v1.2.12c
Fri Oct 26 10:12:41 2007 - Initialize, main threadId= 180
Fri Oct 26 10:12:41 2007 - File watcher thread created.
Fri Oct 26 10:12:41 2007 - GetFilterVersion
Fri Oct 26 10:12:42 2007 - HttpFilterProc SFNOTIFYURL_MAP
Fri Oct 26 10:12:45 2007 - HttpFilterProc SFNOTIFYLOG
Fri Oct 26 10:12:45 2007 - HttpFilterProc SFNOTIFYURL_MAP
Fri Oct 26 10:12:45 2007 - HttpFilterProc SFNOTIFYLOG
Fri Oct 26 10:12:45 2007 - HttpFilterProc SFNOTIFYURL_MAP
Fri Oct 26 10:12:45 2007 - HttpFilterProc SFNOTIFYAUTH_COMPLETE
Fri Oct 26 10:12:45 2007 - DoRewrites
Fri Oct 26 10:12:45 2007 - New Url: '/sePlugins/iisWASPlugin_http.dll'
Fri Oct 26 10:12:45 2007 - ApplyRules (depth=0)
Fri Oct 26 10:12:45 2007 - Rule 1 : 1 matches
Fri Oct 26 10:12:45 2007 - EvaluateCondition: checking 'intranet11.canam.ws' against pattern '^(.*)canam\.ws$'
Fri Oct 26 10:12:45 2007 - Cond : 2 (match)
Fri Oct 26 10:12:45 2007 - EvaluateConditionList: TRUE, Rule will apply
Fri Oct 26 10:12:45 2007 - Result (length 50): http://intranet11-auth.canammanac.com/homepage.nsf
Fri Oct 26 10:12:45 2007 - Last if Match
Fri Oct 26 10:12:45 2007 - ApplyRules: returning 1
Fri Oct 26 10:12:45 2007 - Rewrite Url to: 'http://intranet11-auth.canammanac.com/homepage.nsf'
Fri Oct 26 10:12:45 2007 - HttpFilterProc SFNOTIFYURL_MAP
Fri Oct 26 10:12:45 2007 - HttpFilterProc SFNOTIFYLOG

As you can see, my URL is rewritten to "http://intranet11-auth.canammanac.com/homepage.nsf", which is a correct URL (Intranet).

I don't understand why I receive a 404 error.
Can somebody help?

Thanks!
Oct 31, 2007 at 2:50 PM
Nobody has seen this before or has an idea on how to solve this?
Coordinator
Nov 21, 2007 at 11:21 AM
you have to un-install WebSphere.

HA HA !

have you checked the IIS log - maybe the 404 is getting generated by something else like URLSCAN ?

Does the resulting URL work if you type it directly in the browser?

Nov 21, 2007 at 1:13 PM
I can't uninstall the WebSphere plug-in... I really do need it.
Everything is fine in the IIS log.. and the resulting URL does work when I type it directly in the browser.

Thanks!