IIRF at Windows 2003 64bit

Aug 5, 2010 at 2:31 PM



I downloaded the IonicIsapiRewriter- file, did all configuration as before... when I run at first time, I got a error, and I run the cscript as I read at MS



as follow

C:\Inetpub\AdminScripts>cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 true

Microsoft (R) Windows Script Host Version 5.6Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

Enable32BitAppOnWin64           : (BOOLEAN) True

And I still getting the same error


Event Type: Error

Event Source: W3SVC-WP

Event Category: None

Event ID: 2274

Date: 05/08/2010

Time: 11:18:10

User: N/A

Computer: NS212076

Description:ISAPI Filter 'D:\Web\IIRF\Iirf.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.Data:0000: c1 00 00 00               Á...    

What I have to do?



Aug 5, 2010 at 4:07 PM



It´s weird, because I did a test with IonicIsapiRewriter- and works fine... now I have the IIRF working fine... 


I´ll try more with 64 bit later... but now I have to move lot´s of web sites to the new server.

Aug 7, 2010 at 6:32 PM



I thought that I did well, but even after change all permissions, at plesk  I still cannot use it.

The ISAPI is running fine, the httdocs network and IUSER have the correct rights, but still not working...

I did the drive test and it works fine... but the Log was not written at Log folder...

I do not know what can I do.

Any one is using the IIRF with Plesk 9.5?

Aug 23, 2010 at 9:21 AM
Edited Aug 23, 2010 at 9:56 AM

Nevermind.... wrong topic

Aug 23, 2010 at 12:18 PM


The IIRF is working fine... I had to make some changes at:

C:\Program Files (x86)\Parallels\Plesk\etc\hosting_template.xml to give the rights for IIRF to work... 

I´m using the IIRF 32bit making it run as 32 bit in a 64bit environment...