Rewriting URLS showing funky characters on WinXP Pro

Feb 19, 2008 at 8:51 PM
On Vista x64, my rules seem to work ok.

On Windows 2000 and XP Pro, my rules don't match.

Here is a sample rule:

RewriteRule ^/abc/read/(A-Za-z0-9+).(png|PNG|jpg|JPG|gif|GIF) /abc/read.ashx?code=$1

for hitting a url like /abc/read/333736353930393831.gif

Note: I have also tried using the following flags on the rule: R,U,I

On XP/2000, my log file shows stuff like this:
Tue Feb 19 15:34:18 2008 - HttpFilterProc SFNOTIFYLOG
Tue Feb 19 15:36:08 2008 - HttpFilterProc SFNOTIFYURL_MAP
Tue Feb 19 15:36:08 2008 - HttpFilterProc SFNOTIFYAUTH_COMPLETE
Tue Feb 19 15:36:08 2008 - DoRewrites
Tue Feb 19 15:36:08 2008 - GetServerVariable_AutoFree - no joy (likely reason: server var not set yet) (GetLastError()=1413)
Tue Feb 19 15:36:08 2008 - New Url: 'À|'
Tue Feb 19 15:36:08 2008 - ApplyRules (depth=0)
Tue Feb 19 15:36:08 2008 - Rule 1 : -1 (No match)
Tue Feb 19 15:36:08 2008 - Rule 2 : -1 (No match)
Tue Feb 19 15:36:08 2008 - ApplyRules: returning 0
Tue Feb 19 15:36:08 2008 - No Rewrite


Occasionally it works, like this example:

Tue Feb 19 14:38:21 2008 - GetServerVariable_AutoFree - no joy (likely reason: server var not set yet) (GetLastError()=1413)
Tue Feb 19 14:38:21 2008 - New Url: '/abc/read/2D353737313636363834.gif'
Tue Feb 19 14:38:21 2008 - ApplyRules (depth=0)
Tue Feb 19 14:38:21 2008 - Rule 1 : 3 matches
Tue Feb 19 14:38:21 2008 - Result (length 49): /abc/read.ashx?code=2D353737313636363834
Tue Feb 19 14:38:21 2008 - ApplyRules (depth=1)
Tue Feb 19 14:38:21 2008 - Rule 1 : -1 (No match)
Tue Feb 19 14:38:21 2008 - Rule 2 : -1 (No match)
Tue Feb 19 14:38:21 2008 - ApplyRules: returning 0
Tue Feb 19 14:38:21 2008 - ApplyRules: returning 1
Tue Feb 19 14:38:21 2008 - Rewrite Url to: '/abc/read.ashx?code=2D353737313636363834'
Tue Feb 19 14:38:21 2008 - HttpFilterProc SFNOTIFYURL_MAP

Thanks for any help!