No log file is created in c:\temp\iirf

Topics: Developer Forum
Dec 29, 2010 at 10:52 PM

What Are The Reasons That possible not is the log file generated?.

I found in this post:

I think what you are seeing is, No IIRF log file.    IIRF will NOT create a log file, in the following circumstances:

  • IIRF is not configured properly.  Like maybe there's an incorrect path to the ISAPI filter. In this case IIS cannot load IIRF, and so IIRF can't do anything.
    Usually this is not a problem if you use the MSI to install IIRF.  If you have this problem, you will clearly see Windows Event log messages saying "IIS could not load ISAPI Filter xxxx".  See the "verifying and troubleshooting" section in the IIRF documentation for the exact details on this.
  • No request has flowed through IIS.  In this case IIRF will not load, and so obviously it will not create a log file.
  • No request has flowed through the vdir for which you have an IIRF ini file.  Same as above.
  • There's no IIRF.ini file in the web root for the vdir in question,
  • IIS cannot READ the ini file. 
    I've seen this happen if you, for example, create the ini file in one directory, then MOVE it to the web root directory.  In this case the original ACL on the file will travel with it, and it may lack the access to allow the IIS identity to read the file.  The effect is the same as no ini file at all.
  • The ini file is empty, or there's no RewriteLog directive in the  IIRF.ini file, or there's no RewriteLogLevel directive in the IIRF ini file.
    In this case, IIRF will assume you don't want logging.
  • The IIS identity does not have permissions to create a log file in the designated directory.
    In this case you should see a message in the Windows Event Log .

And check all these reasons and still not get the log file I generated, I have made the process many times on different servers and always arrive at the same point .. when I create the document root Iirf.ini the 404 error I get and I http://localhost/iirfStatus generates the log file in c: \ temp \iirf not going that is what I need,  I read every post, and some find that they have been exactly the same. but in the next post say "Usually we work for me, but do not say how they worked and they had to do, please help would appreciate much, I'm not an expert administrator, and not you are doing wrong, or me is missing ..

Thank you very much.

Dec 30, 2010 at 3:21 PM

Any Idea?

Jan 3, 2011 at 1:45 PM

Is this still a problem?

Jan 3, 2011 at 3:26 PM

yes sir, I have reviewed the permissions on the folder c: \ temp has full control for the group and check the file IIS_WPG IIRF.ini and is at the root. the site, and have the following.


# IIRF.ini

RewriteLog  C:\temp\iirf
RewriteLogLevel 3
StatusInquiry ON


I've made the process from scratch many times, I verify that is running the isapi filter that permits are those who say the documentation. but can not get by me nowhere generate IIRF.ini error log.



Jan 3, 2011 at 3:55 PM

I am not clear on the exact nature of the problem you are experiencing.

I think that you have 2 discussions open here on the IIRF forums site.  I am not sure if we are dealing with 2 distinct problems, or just one.

I think that you are not seeing an IIRF log file being generated.  As you have seen, I've covered this question in the IIRF documentation and in other discussion threads. I don't know what else to add to those sources of information.

If you believe that you have followed everything correctly, then I suggest you go back, and clearly document that all your settings are correct.  In your next post, include a screenshot of the ISAPI Filter management screen, showing a happy green up arrow, and the associated path for IIRF.dll.  Include a screenshot of the cmd window where you verify the access control on the IIRF.ini file, using the icacls.exe program.  and so on, for each item in the list of things to check.  Sometimes it helps to be very very methodical about these things.

Jan 3, 2011 at 4:49 PM

Thanks for your answer, then send you the screenshots of the process in the respective order  a your email.


Thanks very much