Service Unavailable after IIRF install

Feb 7, 2011 at 9:31 PM

Hello guys,

after I installed IIRF i can not open my website "Service is not avaiable".

First i have an virtual server with microsoft windows 2003 64 bit, plesk and iis6 (hosteurope).
I installed "IonicIsapiRewriter-" as described in the tutoriall for 2.1 under iis6..
Now i wrote my steps maybe anyone can say me where my mistakes are ..

I copied the downloadet files from the BIN folder to
C:\Program Files\Ionic Shade\IIRF 2.1
Then i created the "IirfGlobal.ini" in the same folder (where the dll "IIRF.dll" is) C:\Program Files\Ionic Shade\IIRF 2.1 ...
and i give theeese two files READ permissions (DLL, and ini file)..
Then (Step4) i browsed to the IirfGlobal.ini file and to the IIRF.dll and specified the NETWORK SERVICE for the identity verify permissions.
(Yes everything was checked List folder / read data ..)

After that i moved to the ISS, right clicked "Web Sites" and addet the ISAPI Filter.
(I left out step 10 -  it was optional.)

After that i checked the "Web Service Extensions"  but i could not find "Ionic Rewriter", so i checked in IIS on "Web Sites" the ISAPI FILTER.
I think there is the problem, the Ionic Rewriter is red, priority unknown and status not loadet.

I wrote in the "IirfGlobal.ini"
RewriteFilterPriority HIGH
NotifyLog OFF
StatusInquiry ON
RewriteEngine ON

But i think that is not the problem hmn I need only rewrite to use cooluri or realurl for my typo3 i think thats more comfortable..

If anyone could help me i would be very happy..

Greetz mimo

Feb 8, 2011 at 11:50 AM

Check the Windows event log.

Also, see the page in the documentation called "verifying and troubleshooting installation"

Good luck.


Feb 8, 2011 at 12:58 PM
Edited Feb 8, 2011 at 3:26 PM

I wrote with my Serverhoster ...
They said that the server use 64bit but the iis runs under 32bit ..
I think thats my problem.


now it works

Feb 8, 2011 at 10:15 PM

the ISAPI Filter is now loadet under iis but if i look to the log files i have every few minutes  this error message:
IIRF: event ID 3, IIRF:
Could not open ini file 'C:\Inetpub\vhosts\default\htdocs\Iirf.ini' (error: 2).

If i type "http://localhost/iirfStatus" i get this feedback:
IIRF Status Report
IIRF Global Status
IIRF Version    Ionic ISAPI Rewriting Filter (IIRF) x86 RELEASE
Built on    Jan 7 2011 07:30:24
Filter DLL    C:\Program Files\IIRF\IIRF.dll
PCRE Version    8.02 2010-03-19
IIRF Started    2011/02/09 00:10:23 W. Europe Standard Time
Current time    2011/02/09 00:11:11 W. Europe Standard Time
Server Ini file    C:\Program Files\IIRF\IirfGlobal.ini
Last Update of Ini    2011/02/08 23:08:06 W. Europe Standard Time
  #Lines    5
  #Warnings    0
Rewrite Engine (all vdirs)    ON

IIRF Vdir Status
Ini file    C:\Inetpub\vhosts\default\htdocs\Iirf.ini
Ini file timestamp    (file not found)
  Last read    2011/02/09 00:10:23 W. Europe Standard Time
  #Ini Modules    0
  #Lines    0
  #Rules    0
  #Warnings    0
  #Errors    0
Log file    (none)
Log level    1
Rewrite Engine    ON
Rewrite Base    '--'
Remote Status Inquiry    disabled
URL Decoding    ON
Iteration Limit    8
Proxy Timeouts (sec.)    Resolve=30 Connect=30 Send=30 Receive=30
#Requests Processed    2

I dont know what to do (im a newbie with iis)  but i hope my information is good enough to analyse it...

greetz mimo

Feb 10, 2011 at 12:53 PM

Well, this error:

> IIRF: event ID 3, IIRF:
> Could not open ini file 'C:\Inetpub\vhosts\default\htdocs\Iirf.ini' (error: 2).

...says that IIRF could not open its ini file.  Error 2 indicates the file does not exist, but you wouldn;t know that unless you were a programmer.

This set of messages:

> Ini file    C:\Inetpub\vhosts\default\htdocs\Iirf.ini
> Ini file timestamp    (file not found)

says the same thing, though, in English.

I think you need to provide an Iirf.ini file, with rules in it.  This is explained in the IIRF documentation. I highly recommend reading it.

Jul 19, 2012 at 8:33 PM

I had a similar problem.  You have to look at your iirfStaus on the server.  If your vdir .ini gets a Event ID 3, make sure you give the same permissions to your Iirf.ini that you gave to the IIRF.dll and IirfGolbal.ini.