Bug or rule problem?

Topics: User Forum
May 30, 2008 at 10:09 AM
I'm not sure if I am doing something wrong in the config here, or if there is a problem with the filter.  I have a rule like this:

RewriteCond %{HTTP_HOST} ^www\.(gowerpublishing|gowerpub)\.com$
RewriteRule ^/$     /default.aspx?page=295 [I]

It works almost as I expect, except when you visit www.gowerpublishing.com, the address bar changes to www.gowerpub.com.  It may be that I just haven't done it correctly, or maybe something is wrong in the filter, but I can't figure it out.  Any ideas or advice would be welcome

Thanks in advance
Peter

PS.  Thanks also to the developer for writing this software and making it open source

Coordinator
May 31, 2008 at 12:10 AM

changing to gowerpub.com won't happen with the rule you have defined.

It seems like it would be a server or DNS-redirection thing that is happening outside of IIRF.

Maybe some more testing?  Are you sure it happens only when IIRF is enabled?

Jun 2, 2008 at 10:08 AM
You're absolutely right - assumed that the domain was at least pointing to the right server, whereas it was really a redirect, so nothing to do with IIRF at all!  Sorry for wasting your time, and thanks again for some really useful software.
Coordinator
Jun 2, 2008 at 4:38 PM
no problem,
glad you are finding the filter useful.
Coordinator
Jun 19, 2008 at 6:11 AM
ps: don't forget, IIRF is now donationware.
I am now accepting donations on behalf of my favorite charity.
If you find IIRF useful, consider donating.