OutputCache and FilterEnableCache?

Topics: User Forum
Jul 16, 2008 at 8:04 PM
Hello,

The OutputCache directive has stopped working after installing the Ionic Rewriter ISAPI filter. Is there some setting in the .ini file that will fix this? I've checked IIS settings with the Metabase Explorer, and FilterEnableCache looks like it's set to 1, but maybe some info needs to be added to the metabase in the Filters section? Any help would be appreciated.

Thanks,

Alex
Coordinator
Jul 16, 2008 at 11:57 PM
Edited Jul 16, 2008 at 11:57 PM
What OutputCache directive? 
where is it used?  It's not an IIRF thing.  


It's possible if you are using [U] rules in your ini file that you will disable Kernel-mode output caching by IIS.  This is documented in the readme. Is that what you're referring to?
Jul 17, 2008 at 12:21 AM


Cheeso wrote:
It's possible if you are using [U] rules in your ini file that you will disable Kernel-mode output caching by IIS.  This is documented in the readme. Is that what you're referring to?

Yes, I believe that's what's happening. So it looks like the solution is to remove [U]. Please post if there are other possible solutions.
Coordinator
Jul 17, 2008 at 6:03 PM

Yes, The [U] flag has the unfortunate side effect of disabling the kernel cache.

In future versions of IIRF I'm going to make that an explicit option in the ini file - rather than a hidden side-effect. In other words, you'll have to use an option like "EnableUnmangling" as a directive, and in the doc for "EnableUnmangling" it will say, "This also disables the kernel cache."

Or something along those lines.