error 500

Nov 22, 2009 at 12:52 PM
Edited Nov 22, 2009 at 12:52 PM

I installed IIRF on Windows 7 x64, but I have got problem. Every time when I try to views site I got error 500. I have no ideas how to fix it. Could you help me?

http://img688.imageshack.us/i/iis.png/

 

Coordinator
Nov 22, 2009 at 2:50 PM

Luca, it looks like a permissions error.  I can't read the text, but I'm guessing Windows 7 cannot read or load the DLL.

( I've never tested IIRF on Windows 7. )

 

Nov 22, 2009 at 3:37 PM
Edited Nov 22, 2009 at 3:53 PM

What I can to try to do?

I'm not sure that it best varian but look at picture http://img687.imageshack.us/i/iis1.png/ to what I may try to push?

I tried to add IIS user with read, exacult permissions but didn't it helped http://img502.imageshack.us/i/iis2.png/

If it will be easy for you you may look at my PC with TeamViewer? Do you have any chat system for arrange about the time?

 

P.S. text on picture mean: "Call failed LoadLibraryEx in ISAPI filter"

 

Coordinator
Nov 23, 2009 at 4:18 AM
Edited Nov 23, 2009 at 4:18 AM

I don't know what you can do.

I suggest you follow the instructions that I wrote in the help file, again.

I want to repeat that I've never tried installing IIRF on Windows 7, and I don't know if it works there.

I don't know if there have been changes for ISAPI filters on Windows 7 that would prevent IIRF from running on Windows 7. 

 

Feb 15, 2010 at 5:28 PM

If this hasn't been answered yet...

Luca - you're using windows 64 bit...the ISAPIRewrite4 module is a 32 bit application.

Fortunately, this is easy to work around with IIS7.

Please go here http://www.codedigest.com/Articles/IIS/21_IIS7_-_Running_32-bit_and_64-bit_ASPNET_versions_at_the_same_time_on_different_worker_processes.aspx

That will explain how to enable 32bit applications on your 64bit machine.

I'd recommend you create a separate application pool to assign your web site too, if you're running multiple sites.

Good luck!